change display colors problem

Help and advice on using PocoMail

Moderators: Eric, Tomas, robin

change display colors problem

Postby Cliff » Sat Sep 04, 2004 1:08 pm

I would like to change the display colors that appear when I reply to an email. Currently, when I'm in the email reply window, there is a white font on a white background color for the line of text that reads: reply, reply all, forward, bounce, delete.

Although I have experimented with the 'display preferences - change display colors' window, I have not been able to change this white on white color scheme. None of the 'font' color boxes within this 'customize' window are white; personally, I've choosen a red font on a black background throughout the Poco interface. Yet this white font on a white background solely within the email 'reply' window persists.

Any tips on how to change this incompatible color scheme are greatly appreciated. Thanks in advance.
Drop-in Visitor
Posts: 8
Joined: Fri Sep 03, 2004 9:26 am

Re: change display colors problem

Postby Pete » Sun Sep 05, 2004 10:49 am

Cliff wrote:Currently, when I'm in the email reply window, there is a white font on a white background color for the line of text that reads: reply, reply all, forward, bounce, delete.

Where do you see this in the reply window? What's above, below, or next to it?

Postby Cliff » Sun Sep 05, 2004 5:44 pm

Immediately 'above' this white on white band of text are the following pull-down menus: file, edit, view, insert, message, format, help.

Immediately 'below' this white on white band of text is the following text and graphic: headers, a picture of a happy face, rr, show, normal, plain.

And below the 'headers' line are the 'from,' 'to' and 'subject' lines.

These surrounding areas are not at all affected by this band of white on white font and background color scheme.
Drop-in Visitor
Posts: 8
Joined: Fri Sep 03, 2004 9:26 am

Postby Pete » Mon Sep 06, 2004 12:14 pm

Okay, that's the toolbar. As you have also discovered, I have never been able to find a direct way to change these colors to ones that I want.

With that said, however, I'll tell you what I do. First, look at "Tools > Customize > Colors". Toward the bottom-right, there's a drop-down box that's labelled "Skins". If you click on that, and then click on "<Windows Preset>", then I believe that PocoMail will use the colors that you've defined in "Microsoft Windows' Control Panel > Display > Appearance". So try this now if you want:

1) Click on the drop-down box, then click "<Windows Preset>".

2) Click on the drop-down box again, then click"<the name of your skin>"

3) Click OK.

On my computer, this gives me the colors that I want, without the bright white toolbars that PocoMail uses by default. The problem is that, even though PocoMail saves all of these colors to its INI files when you close PocoMail, it ignores the saved color for the toolbar background color when you start PocoMail again, so the toolbar reverts to the white color. Yes, this is annoying, and I've entered a bug report in Bug Traction (#669).

As a temporary workaround, I use automation software to do the three steps (above) each time that I start PocoMail.

Since PocoMail obviously has the ability to easily change the toolbar colors whenever it wants, I would like to see them fix this somehow. I can think of three solutions off the top of my head: (1) let us directly customize these colors in "Tools > Customize > Colors", or (2) fix the aforementioned bug, or (3) always use the system colors like it does when we select the <Windows Preset> skin.

Now so far, I've really only been talking about the background color of the toolbar. For the foreground (i.e. font) color, I always see black text. I see black text when I use PocoMail's default white toolbar, and I see black text when I use my own colors. This is true regardless if I use WinXP's blue "theme", or if I use WinXP's "classic" colors.

So at this point, it's a mystery why you're seeing white text, but it seems to me that this is something that you have set somewhere, rather than something that PocoMail forces you to use. The question is, where might you have set this? If, as you said, you didn't set it in PocoMail, then I would look in the Display settings in Windows Control Panel.

In the past (and maybe still), PocoMail had a strange dependency between its toolbar and one of the colors defined in Control Panel. PocoMail would use the color value as the value for the transparency setting of the buttons on the toolbar. So if for example you used a white color (RGB value 255,255,255), then you couldn't see any of the buttons on the toolbar. If you used a black color (RGB 0,0,0), then you could see them completely. (This was true regardless of the toolbar's background color.) As you increased the value for the color from black to white (0 to 255), the buttons would become increasingly transparent until they became completely invisible!

I suggest that you look at the colors that you're using in "Control Panel > Display > Appearance" and look for a setting of white. Try changing it to black and see if it affects PocoMail. You might have to restart PocoMail before you see a possible change in PocoMail.

Postby Cliff » Tue Sep 07, 2004 9:37 am

Thanks for the information, Pete. With your instructions and information I have been able to re-configure my Poco colors to a more agreeable color scheme. I now have a toolbar with a black font on a white background. This may be the Poco default, but that's ok, I don't mind this color combination for this part of the Poco interface.

Here's what I did wrong: originally, while I 'manually' set the colors for the fonts and backgrounds in the 'change display colors' window, I failed to then choose a skin. I left this entire option untouched. Going about color changes this way seems to have turned both the font and background of the toolbar white in my case.

But luckily, the 'night' preset skin automatically turns the all backgrounds black, after which I was able to manually turn all the fonts to a red color. And as I noted above, I don't mind the default black on white solely within the toolbar area. Problem solved.

Thanks again for the time and effort you put into this request.
As a Poco user, I appreciate this support very much.
Drop-in Visitor
Posts: 8
Joined: Fri Sep 03, 2004 9:26 am

Return to PocoMail Help and How-To

Who is online

Users browsing this forum: Yahoo [Bot] and 3 guests