[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4688: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4690: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4691: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4692: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
Poco Forums • View topic - Disappearing/Blank email messages [Mod: Resolved]

Disappearing/Blank email messages [Mod: Resolved]

Help and advice on using PocoMail

Moderators: Eric, Tomas, robin

Disappearing/Blank email messages [Mod: Resolved]

Postby jo88 » Fri Aug 25, 2006 7:47 am

I am running version 3.4 and have the following problem:

I closed poco and came back a few hours later & relaunched it. Upon doing this all of the messages in my inbox displayed as if they were there (subject/from/sent/etc...), but when i opened the actual message there were no contents other than the header - completely empty/blank. I sent myself a message as a test and this (any any subsequent emails) are fine. The only messages missing are in my inbox. I have tons of other saved messages elsewhere and they are all there. I have read the postings in the forum and have tried the following with no luck:

closed & opened poco & rebooted
played with headers - full/short, no help
searched on topic i knew existed in recent email - did not find
compressed inbox - all the messages disappeared (but not recent ones)
backed up mail (prior to compress) and then restored it - all the same problems exist as above

and here's something even weirder: by pure happenstance, of the 300+ emails i have in the inbox, i opened one (about 4th earliest received) and it has content, but not it's own. when it dislays before opening, it shows it's proper date, etc...., but when i open it it's header shows TODAY'S date but from/subject/to are proper/old. The content is of 2 or 3 emails that were sent and/or received since the problem, part of them being gibberish generated by what should be images. i haven't opened every message, but a darn good number of them and they are all blank.

i've played around with the filters as well (I really have none in effect), and have checked the toggle image download/sanitize/strip just for the heck of it. no change.

help! any ideas?

thanks!
jo88
New Arrival
 
Posts: 2
Joined: Fri Aug 25, 2006 7:23 am

Postby Sandy » Fri Aug 25, 2006 9:59 am

Compress the folders (you might consider doing a backup 1st).
Sandy
 

Re: Disappearing/Blank email messages

Postby Eric » Fri Aug 25, 2006 10:09 am

Hi jo88 & welcome to Poco Forums, :D
jo88 wrote:I am running version 3.4 and have the following problem:

I closed poco and came back a few hours later & relaunched it. Upon doing this all of the messages in my inbox displayed as if they were there (subject/from/sent/etc...), but when i opened the actual message there were no contents other than the header - completely empty/blank.
:shock: That's weird.
Could be a corrupt index file!

:idea: Perhaps you could try the following:
1. Close Poco
2. Delete the In.idx in your Mail directory and restart Poco
i've played around with the filters as well (I really have none in effect), and have checked the toggle image download/sanitize/strip just for the heck of it. no change.
I don't think your filters could affect your InBox, since you already downloaded those messages.

If the above suggestion doesn't work, I guess the only thing to do would be to restore the In.mbx from your backup by copying that file to your Mail directory. Close Poco prior to performing that action.

Let me know if it worked or not. :wink:
Eric
 

Disappearing/Blank email messages

Postby jo88 » Sat Aug 26, 2006 5:39 am

Eric - thanks for the tips. Yeah, weird indeed. Another friend of mine who knows a lot about computers suggested it might a corrupted index file as well.

Anyway, i tried what you suggested and neither of them worked. When i deleted the In.idx and restarted Poco, all the problem messages in question disappeared - the newer ones remained. I had copied the original In.idx file to another folder, and when I pasted it back in, I was back to where I started. The more current In.mbx file I had was backed up AFTER the problem, so when I pasted that one in I was right back where I started also - makes sense.

I have a backup from a month or two ago, and when I paste that In.idx file in, it displays all the messages up to that point, but again no contents. When I paste the In.mbx file from the old backup in, all the mail up to that point appears with full content. Another weird thing is that the In.mbx file from a month or two ago is 1.5mb in size. The current In.mbx file is 600kb - obviously a bunch of information has disappeared. I looked through all the folders/files in Poco and can't find them.

It's not a total disaster as I can get pretty current, thanks to the older backup. I'm not going to do this until you reply, and perhaps you have another suggestion of some sort, but to me it looks like my email just disappeared into the ether. Obviously the bigger fear is it happening again for some reason. For all those reading this my suggestion is this: In Tools>Options you can have Poco backup your mail every x number of sessions/days. If I had been using that I'd be able to restore my mail to an even more current version. I'd recommend that you don't make the same mistake as I did of not using that feature.

jo88

P.S. Eric, there are also In.~idx & In.~mbx files. What are those?
jo88
New Arrival
 
Posts: 2
Joined: Fri Aug 25, 2006 7:23 am

Re: Disappearing/Blank email messages

Postby Eric » Sat Aug 26, 2006 6:13 am

jo88 wrote:Eric - thanks for the tips. Yeah, weird indeed. Another friend of mine who knows a lot about computers suggested it might a corrupted index file as well.
You're welcome. :wink:
That's the first idea which came up, when you mentionned your problem.
Anyway, i tried what you suggested and neither of them worked.
Pity, although I already feared that. :?
When i deleted the In.idx and restarted Poco, all the problem messages in question disappeared - the newer ones remained. I had copied the original In.idx file to another folder, and when I pasted it back in, I was back to where I started. The more current In.mbx file I had was backed up AFTER the problem, so when I pasted that one in I was right back where I started also - makes sense.
It seems like your In.mbx is corrupted and not your index file. Problem is to fix this In.mbx., although it's possible I guess.

:idea: If it's not too big, you could send it to my Gmail account and I could perhaps extract each message from that mailbox.
Send me a PM if you would like me to try it.
All information stays confidential of course.
I have a backup from a month or two ago, and when I paste that In.idx file in, it displays all the messages up to that point, but again no contents.
You don't have to paste the IDX-file in, but instead the MBX-file.
When I paste the In.mbx file from the old backup in, all the mail up to that point appears with full content. Another weird thing is that the In.mbx file from a month or two ago is 1.5mb in size. The current In.mbx file is 600kb - obviously a bunch of information has disappeared. I looked through all the folders/files in Poco and can't find them.
Yes, that's the way to go. Paste in the MBX-file. :)
I've been using Barca Pro and although I had problems before with Poco with blank messages (not Poco's fault), I never seen messages disappear.
Very strange indeed, so it would be important to find what's responsible for letting those messages disappear :?:
It's not a total disaster as I can get pretty current, thanks to the older backup.
:!: As with all, a backup or several is always needed in case something happens.
I'm not going to do this until you reply, and perhaps you have another suggestion of some sort, but to me it looks like my email just disappeared into the ether.
See my suggestion above, if you're willing to do that.
Obviously the bigger fear is it happening again for some reason.
I couldn't agree more with you.
For all those reading this my suggestion is this: In Tools>Options you can have Poco backup your mail every x number of sessions/days.
Yes, always make a backup after X nummer of sessions.
Also make sure Poco retains a backup of your previous folders.
Don't have 3.4 anymore, so you'll know it better.
P.S. Eric, there are also In.~idx & In.~mbx files. What are those?
Those are the backup files which Poco creates as a security measure, in case something happens.

If you close Poco and rename In.~mbx to In.mbx, it will show your previous folder before the backup. :P
Eric
 

Empty Messages in Junk Folder

Postby Casey » Wed Oct 25, 2006 1:27 pm

I find that many (not all) messages that are placed in my junk folder by the filters have no text in them. Is there some switch that I have set incorrectly? If I change the junk filter to allow a sender, then ask them to resend, the message text appears normally in my In box.

I'm currently running PocoMail 4.1.0.3650
Casey
Poco Tourist
 
Posts: 40
Joined: Fri Nov 19, 2004 5:33 pm

Postby Tomas » Thu Oct 26, 2006 2:42 am

Casey: did you try any of the steps that Eric mentioned?

Compressing Junk mailbox?
Closing Poco, deleting Junk.idx file and restarting?
Or moving the message with no content to Inbox, does it reveal content or not?
Tomas
Pillar of the Community
 
Posts: 1418
Joined: Sun Jul 25, 2004 1:34 am

Postby Casey » Thu Oct 26, 2006 2:58 am

Yep.
Compressing the Junk folder didn't change anything.
Deleting the junk.idx and then compressing didn't change anything.
Moving the message to the In box doesn't show the message text.
Casey
Poco Tourist
 
Posts: 40
Joined: Fri Nov 19, 2004 5:33 pm

Postby Eric » Thu Oct 26, 2006 5:18 am

Casey wrote:Yep.
Compressing the Junk folder didn't change anything.
Deleting the junk.idx and then compressing didn't change anything.
Moving the message to the In box doesn't show the message text.
:!: I guess another step you could do is to change your account setting to Leave Messages on Server (LMOS).

That way if it happens again, you could check immediately on your server. Check afterwards with your webmail.
If those messages do show blank too, then that would mean it's either spam or something is changing these messages.
Could be a spam filter from your ISP or an antivirus changing the headers incorrectly. :?

:idea: If possible, you could extract a unchanged message from your webmail and send it to Support for further investigation.

Other then this, I don't know what's going on.

BTW My first suggestion to send me that MBX still stands.

Hope it helps anyway to find the solution to your problem. :wink:
Eric
 

Postby Casey » Thu Oct 26, 2006 6:58 am

Thanks Eric,

Please send me your Gmail address (if that's where I should send it).

Casey
Casey
Poco Tourist
 
Posts: 40
Joined: Fri Nov 19, 2004 5:33 pm

Postby Eric » Thu Oct 26, 2006 7:09 am

Done :wink:
Eric
 

Postby Casey » Fri Oct 27, 2006 2:31 am

For what it's worth,
Yesterday I unchecked the "Enable Automatic Junk Mail Filtering" box. This morning, I found several new emails in my Junk mailbox dated today.

I'm not sure if this feature requires a restart of PocoMail, so I will try that and see if it makes the change take effect...
Casey
Poco Tourist
 
Posts: 40
Joined: Fri Nov 19, 2004 5:33 pm

Postby Casey » Fri Oct 27, 2006 3:49 am

Even with a computer reboot, new messages are still appearing in my junk mail box...
Casey
Poco Tourist
 
Posts: 40
Joined: Fri Nov 19, 2004 5:33 pm

Postby Casey » Wed Nov 01, 2006 6:47 am

OK, I'm getting really frustrated.

I have Junk Mail Filtering turned off and am still getting emails placed in my Junk folder.
In addition, some emails placed there still have the message contents missing. I just missed a critical email because the sender wasn't previously listed as an accepted sender.
This doesn't happen to emails placed in any other mailbox

How do I shut this *#$$*## feature off ???

Any suggestions will be appreciated.
Casey
Poco Tourist
 
Posts: 40
Joined: Fri Nov 19, 2004 5:33 pm

Postby Eric » Wed Nov 01, 2006 10:34 am

Casey wrote:How do I shut this *#$$*## feature off ???
You already turned your junk mail filter off, so either the setting didn't take or there's another filter active who puts those messages inside your Junk Mail. :?

:!: You could perhaps also try to reset your poco.ini
Close Poco and rename poco.ini to poco_old.ini
Restart Poco

All previous settings will be lost, so best take screeenshots or note it down, prior to renaming that file.

As for those message showing up blank, I guess the best way would be to leave mail on server.
In case there's another one, you could just verify that message through your webmail.

If content present, export that message and send it to Support for further investigation.

Spam filters or an antivirus inserting notifications into the body could also be responsible for it.

A mistery to me, but I do hope you'll find what's causing this behaviour. :wink:
Eric
 

Next

Return to PocoMail Help and How-To

Who is online

Users browsing this forum: No registered users and 5 guests

cron